All in One SEO Pack не работает: что делать?

Пятница, 03 Апр 2009 19:49
all in one seo pack не работает

Еще совсем недавно я был поражен фактом того, что все заголовки на моем блоге стали такими же, как на главной странице. Как выяснилось, проблема была в некорректной работе нашего всеми любимого WordPress All in One Seo Pack'а, а как выяснилось еще дальше, в его конфликте с шаблоном.

Кстати, тем, кто еще не поставил себе Platinum SEO Pack, — cоветую это делать. Не заметите абсолютно никаких отличий от All in One Seo Pack'a, а функционала станет больше :).

Так вот, основные правила, которых следует придерживаться при установке All in One Seo Pack'a, чтобы он работал корректно, следующие:

  1. Плагин работает только, если в вашем header.php между тегами <head></head> вы вызываете php функцию wp_head();, которая и выводит измененные описание, кейворды, контент и тайтл для статьи
  2. Плагин работает только, если ваш header.php подключается к остальным файлам (single.php, home.php, search.php, page.php и т.д.) через вызов php функции get_header(); !!! Подключения типа <?php include('header.php'); ?> и <?php require_once('header.php'); ?> не конают!
  3. Плагин может не работать из-за конфликтов с вызовом query_post();. Лично у меня получилось так, что один раз при помощи query_post (); выводилась сама статья, а второй раз эта функция вызывалась для вывода последних статей по дате в сайдбар. После того, как я убрал повторный вызов query_post (); , проблема исчезла.

Вот и все. Надеюсь, что кому-нибудь это поможет.

Постовой

Системы безопасности и цифровая телефония для тех, кто хочет идти в ногу с прогресом.

http://blogto4ka.ru

RSS комментариев

13 комментариев Комментировать

  1. centoff пишет:

    04 Апр 2009 в 14:33 Reply to this comment

    1

    тьфу-тьфу мой работает нормально, качал руссифицированный у кактуса

  2. Антон пишет:

    28 Июл 2009 в 11:30 Reply to this comment

    2

    Спасибо за разъяснения, сам промучился с этим плагином

  3. vakcinator пишет:

    29 Июл 2009 в 22:33 Reply to this comment

    3

    Благодарю за подсказку с wp_head();. Я удалил эту функцию сразу после установки плагина (дань моей поранойе), потом долго сетовал на тему, которая, как мне казалось не поддерживает Platinum. Еще раз спасибо

  4. nikolas_sharp пишет:

    30 Июл 2009 в 8:52 Reply to this comment

    4

    Рад, что статья оказалась полезной. Сам как-то больше суток наверное убил, чтобы разобраться, но оно того стоило.

  5. Yury пишет:

    13 Авг 2009 в 9:51 Reply to this comment

    5

    благодарствую! тоже в другой теме не было вывода wp head. добавил, и всё заработало ;)

  6. DOMовой пишет:

    29 Авг 2009 в 23:03 Reply to this comment

    6

    интересно, что еще может влиять на «все заголовки на моем блоге стали такими же, как на главной странице», ибо все основные три правила выполнены, а воз и ныне там.

    Помогает только отключение и дезактивация плагина «All in One SEO Pack», что не есть гут. Да и Platinum SEO Pack не поставишь, забросили его походу.

  7. nikolas_sharp пишет:

    29 Авг 2009 в 23:38 Reply to this comment

    7

    В вашем случае, если все правила выполнены, возможен конфликт с другим плагином. Отключайте по очереди плагины и следите, когда пропадет ошибка. Так и установите.

  8. Иван пишет:

    14 Дек 2011 в 0:29 Reply to this comment

    8

    Ни один из установленных плагинов на моем сайте, не доставил таких проблем , как All in One SEO Pack. Начну по порядку.Скачал, установил, в общих настройках все прописал и установил галочки. На главной странице и на статичных страницах все мета-теги, которые прописываю , устанавливаются правильно, но в статьях категорий рубрик, где я прописываю для каждой статьи мета-теги, они категорически не хотят отображаться  в коде страницы.Думал. что может конфликтуют плагины, но когда начал по очереди отключать плагины, то проблему не увидел. Сам плагин, уже перестанавливал несколько раз, но все по прежнему.Может Вы подскажете решение проблемы. Заранее Вам благодарен.

  9. nikolas_sharp пишет:

    14 Дек 2011 в 2:53 Reply to this comment

    9

    @Иван, я не увидел на вашем сайте это проблемы. Ссылку потер ;) .

  10. Артем пишет:

    10 Июн 2013 в 16:45 Reply to this comment

    10

    Плагин не заменяет keywords и description. Ваши советы к сожалению не помогли.Что можно еще сделать?

  11. nikolas_ sharp пишет:

    10 Июн 2013 в 19:26 Reply to this comment

    11

    @Артем, выключить кеширование, убедиться, что для проверяемой страницы используется шаблон страницы в wp_head (), обновить плагин, проверить еще раз wp_head () в теме, поотключать плагины по очереди, чтобы определить, какой может мешать. Вариантов тысячи. Все зависит от конкретной настройки сайта.

  12. Виталий пишет:

    14 Сен 2013 в 17:23 Reply to this comment

    12

    Здравствуйте! У меня тоже проблема с плагином All in One SEO Pack. Первый пункт из ваших рекомендаций я пробовал — оказалось , что php функция wp_head (); — у меня стоит. Вероятнее всего у меня проблема с в том, что header.php не подключен к остальным файлам. Не могли бы вы подсказать пошагово как это сделать???

  13. Елена пишет:

    04 Сен 2015 в 14:15 Reply to this comment

    13

    Вот и мой сайт проблема неожиданно настигла!! Буду смотреть и решать сейчас

Оставьте свой комментарий о материале
(Комментарии со ссылками попадают на модерацию. Остальные не попадают, но я могу удалять те, которые посчитаю бесполезными, не несущими смысловой нагрузки)